COMR

Communications Réseaux

Configuration d'un commutateur

Pour les besoins du TP, nous allons mettre en service un commutateur de niveau 2. Nous allons récupérer les adresses MAC de chaque ordinateur de notre banc :


PC1 : 34-17-EB-96-80-57
PC2 : 00-21-9B-73-40-C5
								

Une fois les MAC récupérées, on se branche au switch avec un câble console afin d'entamer la configuration. Ainsi, on va pouvoir créer un VLAN puis un VLAN d'administration, mettre en place le Telnet et donner le réseau au port 0/1.


Dindon#conf t
Dindon(config)#interface vlan 99
Dindon(config-if)#no shut
Dindon(config-if)#ip address 192.168.1.1 255.255.255.0
Dindon(config-if)#end
								

Dindon#conf t
Dindon(config)#interface fastethernet 0/1
Dindon(config-if)#switchport mode access
Dindon(config-if)#switchport access vlan 99
Dindon(config-if)#end
								

Dindon#conf t
Dindon(config)#enable secret Pint@de
Dindon(config)#line vty 0 15
Dindon(config-if)#password P0ul€t
Dindon(config-if)#login
Dindon(config-if)#end
								

Ensuite, nous allons afficher la table de commutation du switch. Elle contient les adresses MAC rattachées à chaque port. Pour l'afficher, il suffit de taper :

show mac address-table

On va réserver des ports pour des adresses MAC précises.


Dindon#conf t
Dindon(config)#interface fastethernet 0/1
Dindon(config-if)#switchport port-security
Dindon(config-if)#switchport port-security mac-address 3417.EB96.8057
Dindon(config-if)#end
								

Idem...


Dindon#conf t
Dindon(config)#interface fastethernet 0/2
Dindon(config-if)#switchport port-security
Dindon(config-if)#switchport port-security mac-address 3417.EB96.8057
Dindon(config-if)#end
								

On éteint les ports "inutiles"


Dindon#conf t
Dindon(config)#interface range fastethernet 0/3 - 24
Dindon(config-if-range)#shutdown
Dindon(config-if-range)#end
								

Et on fait une règle de sécurité : soit protect (bloque le port) soit restrict (restrictions sur le port) soit shutdown (éteint le port)


Dindon#conf t
Dindon(config)#interface fastethernet 0/2
Dindon(config-if)#switchport port-security
Dindon(config-if)#switchport port-security violation [protect,restrict,shutdown]
								

Et le spanning-tree


Dindon#conf t
Dindon(config)#interface fastethernet 0/2
Dindon(config-if)#spanning-tree portfast